Go Back   Hi-Lo camper travel trailer forum > Chit Chat > General Hi-Lo camper discussion

General Hi-Lo camper discussion The perfect place to discuss your Hi-Lo camper

Hi-Lo camper travel trailer forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1  
Old 06-12-2010, 02:46 PM
Member
 
Join Date: Jun 2010
Location: Utah
Posts: 3
Default 1973 hi lo

my electrical in my trailer is clicking every 10 seconds or so and is unable to hydraulicly lift or use any of my other electrical equipment anybody have any ideas on what I could have that has gone bad.
Reply With Quote
  #2  
Old 06-12-2010, 03:22 PM
RichR's Avatar
Moderator
 
Join Date: Feb 2010
Location: NW PA
Posts: 2,291
Default

Could you explain that a bit more? I don't understand what is clicking or where it is coming from. What all is working and what is not? Is the battery in good condition? There is sure to be somebody here that can help you.
Reply With Quote
  #3  
Old 06-12-2010, 04:03 PM
Member
 
Join Date: Apr 2010
Posts: 23
Default

It sounds like it could be a circuit breaker clicking off and resetting. You might have a short that's causing the breaker to overheat and trip. I would try pulling all of the fuses and insert them one by one until it trips again. Them you can start tracing that branch and find the short. It might be as simple as worn insulation on a wire. I'm no electrician by any means but this is the way I would proceed. Good luck and let us know what you find.
Reply With Quote
  #4  
Old 06-12-2010, 10:56 PM
Member
 
Join Date: Jun 2010
Location: Utah
Posts: 3
Default

So I was coming home from a camping trip in which everything seem to work fine. I flipped my fridge to low volt (I have three settings gas /120/ low volt) to drive home thinking that it would remain charged while plugged into my car. when I arrived home my trailer would not lift and my water pump would not work. I checked the fuses all were good then I thought my battery might be dead. I checked that it read at 12 volts, but this clicking was going on down in my hydraulic box, but I can't isolate exactly were the clicking is coming from but it is definately electrical because the next morning my battery was dead. thanks for all the help
Reply With Quote
  #5  
Old 06-13-2010, 03:14 PM
Member
 
Join Date: Jun 2010
Location: Utah
Posts: 3
Default

found the problem it was a short thanks for the help and remember never to run any wires over your frame were your trailer lowers the clicking was the circut breaker
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:12 PM.


HiLoTrailerForum.com Copyright 2010