General Hi-Lo camper discussion The perfect place to discuss your Hi-Lo camper
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-14-2015, 08:09 AM   #1
Member
 
Join Date: Oct 2014
Posts: 31
Default Electronic Water Heater

My 2008 Classic has an Atwood electronic water heater - automatic ignition is so much easier then lighting the pilot like my older Hi-Lo. My problem is that the flame dies out within 20 seconds after lighting. Everything looks clean and I unplugged the connectors on the circuit board and then reinstalled them after seeing they looked clean as well. What should I consider replacing first?
Attached Images
File Type: jpg DSC00632.jpg (184.2 KB, 10 views)
File Type: jpg DSC00631.jpg (161.2 KB, 7 views)
__________________

Yerg is offline   Reply With Quote
Old 06-14-2015, 12:30 PM   #2
Member
 
Moonstruck's Avatar
 
Join Date: Nov 2014
Location: Tennessee & N. GA. mountains
Posts: 91
Default

I would check the thermocouple connection. If that is not it, replace it. It is a simple fix that is not too expensive.
__________________

__________________
Don and Lou
2703 TowLite
'97 Chev Suburban 2500 Diesel
Tennessee/Greenest state in the land of the free
moonstruckblog.wordpress.com
Moonstruck is offline   Reply With Quote
Old 06-14-2015, 12:53 PM   #3
Member
 
Join Date: Oct 2014
Posts: 31
Default

Thanks. Thermocouple was my first guess as well. I'll give it a try.
Yerg is offline   Reply With Quote
Old 06-15-2015, 12:29 AM   #4
Senior Member
 
RCREYES's Avatar
 
Join Date: Mar 2010
Location: Far West Texas
Posts: 1,179
Send a message via Yahoo to RCREYES
Default

Might want to also check for critters and webs in any of the tube openings.
__________________
"Ruben"
2404T, 2003 2500HD 4X4 GMC Sierra SLT Crew Cab w/Astro camper shell and 2003 Chevy Tahoe LE 4X2
Far West Texas
RCREYES is offline   Reply With Quote
Old 06-16-2015, 06:01 PM   #5
Member
 
Join Date: Oct 2014
Posts: 31
Default

Ends up it was the Thermocouple after all. The replacement cost me $43 and was exchanged in less the five minutes.
Yerg is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Hi-Lo Trailers Worldwide or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 06:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
HiLoTrailerForum.com Copyright 2010