General Hi-Lo camper discussion The perfect place to discuss your Hi-Lo camper
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-20-2012, 08:35 PM   #1
Member
 
Join Date: Jul 2010
Location: BellaVista Ar
Posts: 57
Default top lowers only reluctantly

Have a 1908 hi-lo that lowers only after pressing button several times. I pull the locking cable, raise the top slightly to unlock the top, then press the lower button and nothing happens

Have to go through this maneuver several times before top finally lowers.

Any ideas as to what I can do to remedy this

Also the top shell lower rail by the door is pulling away where the cable is attached. The cable seems attached securely, but the rail is bowed out. Probably happened when the cable was replaced and raised too high a few months after I bought it.

I wonder if a metal bracket or something of that nature could be engineered at a RV repair shop.

Anybody experience this problem ??? I have put some slack in this cable to relieve some of the tension.

Thanks in advance for your comments

Ray
__________________

__________________
1908T bought Sept 2011
2005 Ford F150 Lariat 5.4 Liter
2 Shi Tsu's Eddie and Binky and Muffin the Yorkie
raysnuffer is offline   Reply With Quote
Old 12-21-2012, 09:05 AM   #2
Senior Member
 
Join Date: Jul 2010
Location: central Virginia
Posts: 571
Default

First look for the simple problems. Make sure that the safety latch is unlocking when you pull the cable. Raise the top first then pull the cable. It will take two people to troubleshoot this, one to operate the switch and cable and one to get under the RV to see that the latch is released. Next check the voltage at the lowering valve on the pump when you press the lowering switch. If no voltage then the valve is bad. If the 12 volts is there then you are losing the voltage at a loose or corroded connection or a bad lowering switch. You will need a volt meter and know how to use it to troubleshoot the problem. Hope this helps. Get back here if you have other questions.
__________________

__________________
Jim L & Faye
2805C
2003 Silvarado diesel crew cab
2017 Silvarado, crew cab 1500 6.2L gas w/ 8 speed tranny
central VA
JIM L is offline   Reply With Quote
Old 12-21-2012, 07:06 PM   #3
Member
 
Join Date: Jul 2010
Location: BellaVista Ar
Posts: 57
Default

Thanks Jim.

Your suggestions are a good place to start. I am willing to bet there is some corrosion on some wires causing the lowering process to work sporadically.

I will also check to see if the lock is disengaging when the wire is pulled.

Excellent suggestions .....
__________________
1908T bought Sept 2011
2005 Ford F150 Lariat 5.4 Liter
2 Shi Tsu's Eddie and Binky and Muffin the Yorkie
raysnuffer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Hi-Lo Trailers Worldwide or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 07:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
HiLoTrailerForum.com Copyright 2010
×