RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 
 


General Hi-Lo camper discussion The perfect place to discuss your Hi-Lo camper
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-06-2011, 03:00 PM   #1
Junior Member
 
Join Date: Jan 2011
Posts: 1
Default Hi-lo wont go down.

HELLLLLLLLLLLLLLLP. My 28' HiLo motor will run in the up position but will not let me lower my HiLo when I pull the cable and push switch to down position, and hints on what I might be doing wrong? Only have owned it 3 mos. And haven't had it out overnite yet. Please help. Thank
__________________

Bozo is offline   Reply With Quote
Old 01-06-2011, 03:20 PM   #2
Senior Member
 
PopRichie77's Avatar
 
Join Date: Aug 2010
Location: Quakertown, PA
Posts: 1,074
Send a message via AIM to PopRichie77
Default

The motor doesn't run to let it down, it goes down by gravity, there is a hydraulic release valve in the battery box, it is on the side of the pump with one wire going to it, it also can be released manually, connect a wire to the positive side of the battery, then touch it to the terminal where the one wire is connected the top should go down. Before doing that check fuses inside trailer and the resets that are in the battery box. If it has a master switch is it in the down position?
Do you have a manual?
__________________

PopRichie77 is offline   Reply With Quote
Old 01-06-2011, 04:42 PM   #3
Senior Member
 
PopRichie77's Avatar
 
Join Date: Aug 2010
Location: Quakertown, PA
Posts: 1,074
Send a message via AIM to PopRichie77
Default

I missed something in the previous post. If you try the jumper wire someone has to pull the cable first.
Also push the up switch while pulling the cable, the safety bar may not be releasing.
sometimes you must push the up switch to get the weight off the safety bar so that it will release.
Pull on cable, then push up switch, continue pulling on the cable, then push down switch after the top drops about a foot you can let go of the cable.
PopRichie77 is offline   Reply With Quote
Old 01-06-2011, 09:04 PM   #4
TJM
Senior Member
 
Join Date: Mar 2010
Location: Ballwin,Missouri
Posts: 148
Default

Quote:
Originally Posted by Bozo View Post
HELLLLLLLLLLLLLLLP. My 28' HiLo motor will run in the up position but will not let me lower my HiLo when I pull the cable and push switch to down position, and hints on what I might be doing wrong? Only have owned it 3 mos. And haven't had it out overnite yet. Please help. Thank

What I would try first is make sure it is raised all of the way. Next, pull on your release cable and lower while still pulling on cable. That is how I do mine. Possibly the release cable is broken.
TJM is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Hi-Lo Trailers Worldwide or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 04:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
HiLoTrailerForum.com Copyright 2010
×