General Hi-Lo camper discussion The perfect place to discuss your Hi-Lo camper
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-14-2010, 04:47 PM   #1
Member
 
Join Date: Sep 2010
Location: Union City, Tennessee
Posts: 3
Question 2006 Towlite 17

I have just bought this and on the first trip, I couldn't get the water to heat up. I think I have gas/elect. but not sure?? Am I missing a breaker reset or does the gas need to be on or what. I looked at the book but no conclusions from it.
__________________

Seaknight6 is offline   Reply With Quote
Old 09-14-2010, 08:57 PM   #2
Senior Member
 
PopRichie77's Avatar
 
Join Date: Aug 2010
Location: Quakertown, PA
Posts: 1,074
Send a message via AIM to PopRichie77
Default

Do you have the manual for the hot water heater? There should be a switch for the electric, somewhere on or near the top of the fridge. For the gas part, Gas has to be turned on at the tank. Light the stove top first to get gas thru the system. Yours should have an auto lighter, but you have turn the switch on, located same place as electric switch. Is the master switch in the right position? Could be a breaker also.
__________________

PopRichie77 is offline   Reply With Quote
Old 09-14-2010, 09:25 PM   #3
Senior Member
 
Join Date: May 2010
Location: Ohio North Coast
Posts: 838
Post

The water heater is probably a six gallon Atwood. There is also a switch mounted on the heater itself for it to work electrically. The purpose of this switch was to keep the water heater turned off in case it was accidentally turned on at the control panel. With no water in the tank at the time of production, the heating elements could burn out. Usually the tanks would be turned off from the factory and the dealer would turn them on when they did their prep. So if this switch is in the off position on the tank, the water heater will not work electrically no matter if the electric water heater switch on the panel is turned on.
retiredcamper47 is offline   Reply With Quote
Old 09-15-2010, 07:01 AM   #4
Senior Member
 
PopRichie77's Avatar
 
Join Date: Aug 2010
Location: Quakertown, PA
Posts: 1,074
Send a message via AIM to PopRichie77
Default

Good point there #47, Mine works fine but where is that switch on the tank that you mentioned as I can find no switch on my 2209 and it is a 6 gal Atwood? There is a fuse on the gas igniter module.
PopRichie77 is offline   Reply With Quote
Old 09-15-2010, 11:24 AM   #5
Senior Member
 
Join Date: May 2010
Location: Ohio North Coast
Posts: 838
Post

If memory serves me correctly, it is located on the top side, right rear of the tank. By that, I mean the trailer side of the tank, not the street side. There might be some insulation hiding it.
retiredcamper47 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Hi-Lo Trailers Worldwide or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 11:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
HiLoTrailerForum.com Copyright 2010
×