General Hi-Lo camper discussion The perfect place to discuss your Hi-Lo camper
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-10-2010, 12:52 PM   #1
Junior Member
 
Join Date: May 2010
Posts: 1
Default heater problem

Hi,

I'm a new hi-lo owner and just started up the heater. It starts up fine as per the instructions, but doesn't come back on once the space is heated up. When I checked the plenum it was hot and the reset button was on the off position. It's almost like there isn't enough return air to cool it off. The problem is worse w/
the bed (couch and dining area) fully in use.
__________________

Dallas is offline   Reply With Quote
Old 05-10-2010, 04:00 PM   #2
Moderator
 
Join Date: Apr 2010
Location: Napa,CA
Posts: 874
Default

I had the same problem with my heater, the high limit switch needs to be replaced. This bi-metal disc switch gets weak overtime causing the gas valve not to turn-on. When I was replacing this part, I removed the spark ignitor/sensor and noticed it was dirty. I cleaned it with fine steel wool. Also, check voltage & gas pressure to the heater. Good luck, this worked for me.

LES 97 21ft towlite
campthewestcoast is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Hi-Lo Trailers Worldwide or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 02:36 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
HiLoTrailerForum.com Copyright 2010
×