General Hi-Lo camper discussion The perfect place to discuss your Hi-Lo camper
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-16-2010, 09:37 PM   #1
Junior Member
 
Join Date: Sep 2010
Posts: 1
Default hydraulic pump motor

We have a 1980 Hi-Lo. It will not go up. The motor does not even try to run. We have hooked up the battery cables to a car with no luck. We have bypassed to the motor also with no luck. Does anybody know where we could buy a pump motor????
__________________

TCollis is offline   Reply With Quote
Old 09-18-2010, 08:41 PM   #2
Member
 
Join Date: Jul 2010
Location: San Antonio, Texas
Posts: 75
Default HiLo parts

Hi I have been in contact with Joel who apparently worked in the parts department at the Hi Lo factory. He has advised me that he is in process of moving the parts business to a different location. It may take him a day or two to respond to your message, but I am totally pleased with the way he helped me with my parts need.

Good luck, Richard ror007@aol.com

From: Hi Lo <hiloparts@gmail.com>
To: ror007@aol.com
Sent: Wed, Sep 1, 2010 9:20 am
Subject: Re: Parts for Towlite 2703T
Richard is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Hi-Lo Trailers Worldwide or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 04:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
HiLoTrailerForum.com Copyright 2010
×