New Member Intros Say Hello! Tell us a little about yourself and your camper; we're fairly friendly :)
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-14-2019, 08:54 PM   #1
Member
 
Join Date: Jul 2019
Location: Savannah, Georgia
Posts: 3
Default Help 1984 funlite

Hello all, I have recently bought a hi-lo and have a small problem... it is stuck in the upmost position... I have cleaned up the hydraulic system and wiring is all correct... the safety bar fully engages and disengages when I pull the cable. I have throughly Lubricated all the cables and Pullys underneath the HI-LO and everything is connected correctly... when I hit switch and pull the cable to the up position it makes a Squeal which it says in the 1983 owners manual I found on the forum is normal and means it is in its upmost position and when I hit the button to the lower position a get a click noise by the pump but nothing else.. not sure where to release pressure in the pump or how or if it is possible to fill the Reservoir in the out position...
Jay82 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Hi-Lo Trailers Worldwide or any of its affiliates. This is an independent, unofficial site.


All times are GMT -5. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
HiLoTrailerForum.com Copyright 2010
×